Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2025 - 18:00 CET
Scheduled
🔧 Details: On Saturday, March 22, 2025, we will be conducting scheduled maintenance to improve the performance and stability of our services. During this time, the affected services will be unavailable.
✅ Expectation:
The maintenance is estimated to last 2 hours. All services will be checked and restored immediately after maintenance. 💡 Updates: We will keep this page updated with progress. Thank you for your patience and understanding!
Posted Mar 18, 2025 - 20:00 CET
This scheduled maintenance affected: Minecraft servers (Minecraft java server, Minecraft bedrock server) and TB studio site, Sherlockspeurteam site.